Photoshop CS6 Brush Lag Problems
Join the #1 Art Workshop - LevelUpJoin Premium Art Workshop

Results 1 to 18 of 18

Thread: Photoshop CS6 Brush Lag Problems

  1. #1
    Join Date
    Apr 2012
    Posts
    76
    Thanks
    2
    Thanked 14 Times in 14 Posts
    Follows
    0
    Following
    0

    Question Photoshop CS6 Brush Lag Problems

    I'm experiencing extensive brush lag while using CS6, almost since day one.
    I use rapid brush strokes and every four or five strokes I get a lag spike. With my drawing technique, this renders Photoshop almost unusable.

    I'm using an iMac Mid 2011, 3.1GHz Intel i5, 8gb memory, AMD Radeon HD6970M 1024MB, with OS X 10.8.2, drawing on an Intuos5.
    As far as I'm aware, it should not lag at all on this machine. Hell, it chews up huge HD video files in post production with no trouble, it should not lag when I'm doing a 1000x750 pixel sketch.

    Here are the things that I have tried that have had no effect on this problem:

    - Updated Intuos to latest drivers.
    - Tried turning off "Use Graphics Processor" in PS
    - Reduced "History States" count
    - Switched "Drawing Mode" to "Basic"
    - Tried turning on and off all of the "Advanced Graphics Processor Settings"
    - Worked in smaller file sizes.
    - Reinstalled PS.
    - Reinstalled the whole goddamn OS.

    The problem doesn't go away.
    Does anyone else have this issue and does anyone maybe have a solution?

    The easiest fix would probably be to go back to CS5 or 5.5 but I would like to try and fix this - if at all possible.

    Thanks all.

    SKETCHBOOK

    Everything is going to kill everybody.
    Reply With Quote Reply With Quote  

  2. #2
    Join Date
    Jun 2008
    Location
    Van Nuys, CA
    Posts
    228
    Thanks
    24
    Thanked 94 Times in 49 Posts
    Follows
    0
    Following
    0
    Have you tried changing "Tablet Mode" from "Standard" to "Recognition Data"?

    Reply With Quote Reply With Quote  

  3. #3
    Join Date
    Nov 2012
    Posts
    41
    Thanks
    8
    Thanked 6 Times in 6 Posts
    Follows
    0
    Following
    0
    Is this with all brushes or only the advanced brushes ?

    Reply With Quote Reply With Quote  

  4. #4
    Join Date
    Nov 2012
    Posts
    41
    Thanks
    8
    Thanked 6 Times in 6 Posts
    Follows
    0
    Following
    0
    I found out (at least for me) its an issue with the spacing option of your brush on CS6. Try turning it off on the specific brushes to see if it will go away. You can try messing with the percentage to temporarily fix this untill the patch comes out or someone comes up with a performance solution.

    Reply With Quote Reply With Quote  

  5. #5
    ikken's Avatar
    ikken is offline Her Wings Glow According To Her Mood © Level 8 Gladiator: Thracian
    Join Date
    Jul 2008
    Posts
    1,047
    Thanks
    73
    Thanked 195 Times in 158 Posts
    Follows
    0
    Following
    0
    might be a wacom driver bugging out on 10.8
    http://forum.wacom.eu/viewtopic.php?f=2&t=10672#p42867
    try getting the driver build that poster is referring to

    Reply With Quote Reply With Quote  

  6. #6
    Join Date
    Apr 2012
    Posts
    76
    Thanks
    2
    Thanked 14 Times in 14 Posts
    Follows
    0
    Following
    0
    Quote Originally Posted by burning_chrome View Post
    Have you tried changing "Tablet Mode" from "Standard" to "Recognition Data"?
    This seems to have fixed the problem! I don't want to jinx it, but for now it seems to be working perfectly again.
    I didn't even know there was that option, never would've found it.

    Thanks man!

    And thanks to all others who replied, as well.

    SKETCHBOOK

    Everything is going to kill everybody.
    Reply With Quote Reply With Quote  

  7. #7
    Join Date
    Apr 2012
    Posts
    76
    Thanks
    2
    Thanked 14 Times in 14 Posts
    Follows
    0
    Following
    0
    Hmph.

    It worked for a while, then suddenly the problem returned again.

    I have no idea what's going on.

    I think it even lags a bit in PS 5.5, although much less than in PS6 but still...

    Bah.

    SKETCHBOOK

    Everything is going to kill everybody.
    Reply With Quote Reply With Quote  

  8. #8
    Join Date
    Jun 2003
    Location
    Olympia, WA USA
    Posts
    2,014
    Thanks
    1,861
    Thanked 486 Times in 325 Posts
    Follows
    0
    Following
    0
    Quote Originally Posted by JuliusObviousMagnus View Post
    Hmph.

    It worked for a while, then suddenly the problem returned again.

    I have no idea what's going on.

    I think it even lags a bit in PS 5.5, although much less than in PS6 but still...

    Bah.
    when i get that it's because my histogram is showing on the tabs, cuz it calculates each stroke. I forget which window. hope you get it fixed.

    sehertu mannu narāṭu ina pānāt šagapīru ningishzidda
    abrahadabra
    Reply With Quote Reply With Quote  

  9. #9
    Arshes Nei's Avatar
    Arshes Nei is offline Registered User Level 17 Gladiator: Spartacus' Dimachaeri
    Join Date
    Jun 2006
    Location
    Torrance, CA
    Posts
    6,802
    Thanks
    2,278
    Thanked 4,259 Times in 2,074 Posts
    Follows
    0
    Following
    0
    Could it be the graphics card?

    Reply With Quote Reply With Quote  

  10. #10
    Join Date
    Nov 2009
    Posts
    712
    Thanks
    479
    Thanked 209 Times in 179 Posts
    Follows
    0
    Following
    0
    its a shot in the dark, but have you tried creating a new user account, with nothing but photoshop, and using it there?



    basically to test if its something related to the brush engine or something else.....

    you said it lags every few strokes. does it lag during the actual stroke, or inbetween? have you tried doing some really loooooong strokes (longer in duration to 4-5 of your normal ones), to see if it lags "during" the stroke itself, to see if its a time-interval thing or something related to individual strokes?

    what about making a 100x100px canvas and using a 1px pencil brush, does that lag too?
    or even some other intensive photoshop operations, such as huge gausian blurs or extremely large soft-edge brushes, to see if those lag in the same intermittent manner, or if they lag "even more".

    Reply With Quote Reply With Quote  

  11. #11
    Join Date
    Apr 2012
    Posts
    76
    Thanks
    2
    Thanked 14 Times in 14 Posts
    Follows
    0
    Following
    0
    aks9 it does not lag within the stroke, however long it might be. But the moment I lift my pen and set it down to pull the next stroke, I get a second-long lag. Just enough to disrupt any precise outline work.
    The same thing happens with any canvas size and brush size, I've tested it out quite extensivley.

    Izi is there a way to turn off this calculating of every stroke? Do I just close the histogram tab?

    Quite honestly I've exhausted all the ideas about what could possibly be causing the problem.
    The only thing that remains is if there is some trouble with Mountain Lion and Intuos5 driver, something that screws up their "communication" so to say. I have the latest driver, ofc, but that didn't help at all.

    Really no idea what's going on...

    Last edited by JuliusObviousMagnus; December 19th, 2012 at 07:45 AM.
    SKETCHBOOK

    Everything is going to kill everybody.
    Reply With Quote Reply With Quote  

  12. #12
    Join Date
    Oct 2011
    Location
    Romania
    Posts
    223
    Thanks
    56
    Thanked 54 Times in 53 Posts
    Follows
    0
    Following
    0
    JuliusObviousMagnus,I'm having a similar issue so please don't consider I'm hijacking the thread.

    I just installed Photoshop CS6 and whenever I'm using a bigger brush and making big strokes it lags pretty bad.I tried increasing the spacing but it doesn't really help.
    The normal round brushes seem to work ok but after I start to pick any of the others,they lag.
    It should be noted that after the installation,I started the program and got this message: "Photoshop detected graphics hardware that is not officially supported." when using Oil Paint Filter."

    Edit: I think I found one of the issues and it seems to be the canvas.When I use U.S Paper(24.1 MB) or International paper(24.9 MB) the lagging occurs because the canvases are so big but if I use the Paper preset,I don't get any lag.
    I'm a newb at Photoshop but do you guys have any suggestions about the canvas size and what is a good width and height for general use?

    Thanks in advance.

    Last edited by Kriss_Kringle; December 22nd, 2012 at 04:17 PM.
    Reply With Quote Reply With Quote  

  13. #13
    Join Date
    Apr 2012
    Posts
    76
    Thanks
    2
    Thanked 14 Times in 14 Posts
    Follows
    0
    Following
    0
    Depends on what you're doing. If you want to print something, make the canvas the same size as the print, that is if you want to print A3 then use an A3 canvas - obviously enough
    For sketches and such I usually use something around 1250 x 750 pixels, since I like the widescreen format.

    The problem with lag seems to be increasing and is rendering PS almost unusable.
    I have tried pretty much every solution I've found on the web, to no avail.
    If all else fails, I'll bloody well install Photoshop on my Boot Camp partition and see if the problem persists. Very frustrating, very very.

    SKETCHBOOK

    Everything is going to kill everybody.
    Reply With Quote Reply With Quote  

  14. #14
    Join Date
    Apr 2012
    Posts
    76
    Thanks
    2
    Thanked 14 Times in 14 Posts
    Follows
    0
    Following
    0
    UPDATE:

    The partial solution to the problem seems to be to do the following:

    - Before updating your driver, you must completely purge the old one.
    - To do this, use the Wacom Tablet Utility app found in your Applications folder to uninstall the driver.
    - Sometimes this does not remove ALL the files, and just to be sure go through the following directories and delete all the files as listed in the image below:
    Name:  Screen Shot 2012-12-25 at 2.57.24 PM.png
Views: 4838
Size:  56.0 KB
    - Move the listed files (if any are found) manually to the trash bin, delete them then restart your computer.
    - Install the newest driver.
    - Restart, just in case.

    This seems to have fixed most of the lag issues. Occasionaly the lag comes back, which is usually fixed by simply restarting Photoshop.

    Alright, hope this helps to anyone who has similar issues.

    SKETCHBOOK

    Everything is going to kill everybody.
    Reply With Quote Reply With Quote  

  15. #15
    Join Date
    Apr 2012
    Posts
    76
    Thanks
    2
    Thanked 14 Times in 14 Posts
    Follows
    0
    Following
    0
    UPDATE 2:

    While the drivers were in fact badly installed, and that fixed most of the lag as I mentioned I discovered another weird reason for lag in PS.
    It was Safari.

    I have no idea how or why, but having Safari open in the background severely lagged the program and it would seem it is only Safari.
    If I am running nothing else but PS and Safari - it lags like mad.
    One other time while I was using PS and at the same time downloading huge files, had a PDF open and playing a 4gig HD video at the same time - no lag.

    So, yeah, if anyone else has lag on OS X, try turning off your Safari while you work.

    SKETCHBOOK

    Everything is going to kill everybody.
    Reply With Quote Reply With Quote  

  16. #16
    ikken's Avatar
    ikken is offline Her Wings Glow According To Her Mood © Level 8 Gladiator: Thracian
    Join Date
    Jul 2008
    Posts
    1,047
    Thanks
    73
    Thanked 195 Times in 158 Posts
    Follows
    0
    Following
    0
    does current safari have webgl/opengl acceleration?
    it might be fighting w. photoshop for videocard resources, thus the lag
    HD video is, iirc, still mostly cpu/ram intensive, and mac ram management is done pretty well

    on the fourth day of glitchmas my painter™ gave to me
    four random crashes, three broken brushes, two system hangups & one corrupted workspace
    Reply With Quote Reply With Quote  

  17. #17
    Join Date
    Mar 2008
    Location
    Glasgow, Scotland
    Posts
    92
    Thanks
    115
    Thanked 56 Times in 25 Posts
    Follows
    0
    Following
    0
    I just started getting this problem with CS6 two days ago, it had been working fine since November before that. I've tried everything I can think of, or find online, including everything listed here, but nothing has worked and the problem still remains.

    If anyone has any more help on this, I'd be grateful.

    Feel like my art career is on hold until I can get this fixed.

    Reply With Quote Reply With Quote  

  18. #18
    Join Date
    Apr 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Follows
    0
    Following
    0
    I also have the same problem. It seems that when you enable the use of graphics processor (edit-preferences-performance) the brush gets laggy instead of getting faster, and gets even slower if you put the drawing mode: advanced. I had an ATI HD 5870 512MB GDDR5 and now an ATI HD 7850 2GB GDDR5 and cant see any improvements in PS performance.
    It seems like the programming that uses the GPU is very bad or just limited to work fast on some rare specific graphic cards and I'm not sure witch ones actually take advantage of the GPU use.

    For painting, the only advantage I see when enabling the graphics processor is to view the image perfectly at "odd" percentage zooms (like 48,05%) or other % different than 50/100/200 zooms.

    Disable graphics processor and it gets very fast at the cost of the jaggy image display at odd zooms, and many other exclusive CS6 features that are not so important when painting.

    Allways restart PS when modifying the GPU use in performance to see the changes.

    Reply With Quote Reply With Quote  

Members who have read this thread: 18

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •