I'm always using shortcuts in photoshop, constantly using E, B and ALT

ALT is the eyedropper as everyone knows but also it activates the menu bar File, Edit, Image, Layer etc. (keyboard navigation)
When i'm painting and i use ALT to pick a color and if i do it at my normal speed, many times the menu bar remains active, if i press E the Edit menu open and does not change the tool to erase and i paint instead of erase, this is very annoying.
I can not do things at the same speed because i have to always be aware of the menu bar

I tried the shortcut settings and have not found a way to disable the ALT to activate the menu bar or remove the E from Edit
ALT active the menu bar in all windows programs, i do not know if this can be changed in the system

i'm using Photoshop CS5
Windows 7 64bits
if you know a way to fix this problem, please let me know