Art: any shader artists here?

View testimonialsView Artwork
Results 1 to 7 of 7
  1. #1
    Join Date
    May 2009
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Follows
    0
    Following
    0

    any shader artists here?

    I've got a slight problem with the toon outline

    any shader artists here?

    Basically everything here looks pretty much the way I want it to ('cept the incomplete textures) except for the wing in the right that's all darkened out. Somehow the toon outline I added is spazzing out and actually engulfs the whole wing. (You can see it too on the exhausts on the engine too)

    I know it's not the lighting because can point a light pointed directly at it doesn't change at all

    any shader artists here?

    I have the same problem in here on some of the mountains in this test render (pardon the terrible camera work)



    Some of the mountains are completely grayed out, which, coincidentally, is the color of the toon outline I wanted to add. I didn't actually lay out the UVs for the mountain test which I thought was causing the problem, but when I went to go texture the airplane I found it had the same problems.

    Any idea what's going on?

    Other info:
    -Software = Maya
    -Toon outline is set for offset mesh

    And as always, more stuff about this problem can be found on my blag: http://jgchan.blogspot.com/

    Reply With Quote Reply With Quote  


  2. Hide this ad by registering as a member
  3. #2
    Join Date
    Jul 2008
    Posts
    1,047
    Thanks
    73
    Thanked 195 Times in 158 Posts
    Follows
    0
    Following
    0
    Did you try deleting the history and/or unlocking the normals after you apply ink outline?

    on the fourth day of glitchmas my painter™ gave to me
    four random crashes, three broken brushes, two system hangups & one corrupted workspace
    Reply With Quote Reply With Quote  

  4. #3
    Join Date
    May 2009
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Follows
    0
    Following
    0
    I was getting some pretty funky performance issues with maya so I was constantly deleting the history.

    I'll try that thing with the normals though. Perhaps duplicating it as an inverse messed it up, but the odd thing is that the dark wing was actually the original one

    Reply With Quote Reply With Quote  

  5. #4
    Join Date
    Oct 2007
    Location
    Los Angeles
    Posts
    180
    Thanks
    21
    Thanked 72 Times in 56 Posts
    Follows
    0
    Following
    0
    Hmmm, did you check the normals to see if they were flipped. Happens to me a lot in Maya.

    __________________________________

    SKETCHBOOK

    PORTFOLIO
    Reply With Quote Reply With Quote  

  6. #5
    Join Date
    May 2009
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Follows
    0
    Following
    0
    Looks like that was the problem! Thanks for the help guys

    [edit]

    Still some slight problems

    https://udrive.oit.umass.edu/jgchan/normals_problem.jpg (linked for hugeness)

    I flipped the normals and it solved most of the problem, but now there's a giant black band on the back of the wing. I have no idea what's causing this now, any ideas?

    [/edit]

    Last edited by jgchan; February 12th, 2010 at 03:17 AM.
    Reply With Quote Reply With Quote  

  7. #6
    Join Date
    Jul 2008
    Posts
    1,047
    Thanks
    73
    Thanked 195 Times in 158 Posts
    Follows
    0
    Following
    0
    select the wing and go to display -> polygons -> face normals
    it will show you the normal orientation for each face on the object
    you might will have to select individual faces and flip them manually
    Another suggestion - you could select object, go to the attribute editor and uncheck "doublesided" on the renderstats tab
    so faces with normals not facing camera will be transparent and it will be easier to spot them
    it will also (probably) save you some rendertime too.

    I did use ink feature and it was fine for me (except slow and no mental ray support :x ) but the normals problems are really common.

    on the fourth day of glitchmas my painter™ gave to me
    four random crashes, three broken brushes, two system hangups & one corrupted workspace
    Reply With Quote Reply With Quote  

  8. #7
    Join Date
    May 2009
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Follows
    0
    Following
    0
    The face normals thing ALMOST worked, but according to the 3D teacher at my school, this is an undocumented problem in Maya.

    In case anyone else ever runs into something like this, make sure objects do not have a negative scale or you'll run into all kinds of messed up.

    The quick/dirty fix for me was to go into the vertex mode and just scaling the components there instead of flipping it while in object mode, and now everything works like a charm

    Thanks for the help dudes!

    any shader artists here? (click for larger)

    Reply With Quote Reply With Quote  

Members who have read this thread: 0

There are no members to list at the moment.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
  • 424,149 Artists
  • 3,599,276 Artist Posts
  • 32,941 Sketchbooks
  • 54 New Art Jobs
Art Workshop Discount Inside
Register

Developed Actively by vBSocial.com
The Art Department
SpringOfSea's Sketchbook