Huge problem with gradients

Join 500,000+ Artists

Its' free and it takes less than 10 seconds!

Join the #1 Art Workshop - LevelUpJoin Premium Art Workshop

Results 1 to 8 of 8
  1. #1
    Join Date
    Apr 2007
    Location
    Stockholm, Sweden
    Posts
    120
    Thanks
    1
    Thanked 17 Times in 14 Posts
    Follows
    0
    Following
    0

    Huge problem with gradients

    Happy new year everyone! I keep encountering a big problem with gradients, especially in dark areas of a painting. I'm not aware of it as I begin a painting, but after playing around with different blending modes, gradients and soft edge brushes my images start to crack up. Gradients, especially in the dark areas, appear really unsmooth. Is there anywhere to counter this problem? Help would be greatly appreciated. I'm running CS3 on a 2.66 Imac with 4 GB RAM. Here's a screenshot:

    Attached Images Attached Images  
    Reply With Quote Reply With Quote  


  2. Hide this ad by registering as a member
  3. #2
    Join Date
    Nov 2008
    Location
    Pacific Northwest, USA
    Posts
    60
    Thanks
    18
    Thanked 19 Times in 15 Posts
    Follows
    0
    Following
    0
    My first thought is to isolate the gradient with a selection, copy and paste it in place in a new layer, then apply Gaussian blur. Not sure if that is the best solution, but it's a start.

    Last night I slept like a baby: I wore a diaper.
    Reply With Quote Reply With Quote  

  4. #3
    Join Date
    Apr 2007
    Location
    Stockholm, Sweden
    Posts
    120
    Thanks
    1
    Thanked 17 Times in 14 Posts
    Follows
    0
    Following
    0
    I've checked back on some old work and I realize that this is a problem that happens from the start, but I don't notice it until I get into the really dark darks and zoom in a bit. It sems I get to a point where I need the steps in the gradient to be smaller that what is actually possible on my computer. Thing is I'm still few steps away from pure black so I just feel my monitor should be able to handle it. How do you guys work around this problem?

    Reply With Quote Reply With Quote  

  5. #4
    Join Date
    Apr 2007
    Location
    Stockholm, Sweden
    Posts
    120
    Thanks
    1
    Thanked 17 Times in 14 Posts
    Follows
    0
    Following
    0
    Thanks for the blur suggestion. It didn't work, unfortunately. Gradent is still unsmooth – though in a slightly different way.

    Reply With Quote Reply With Quote  

  6. #5
    Join Date
    Aug 2006
    Location
    Los Angeles
    Posts
    577
    Thanks
    506
    Thanked 645 Times in 232 Posts
    Follows
    0
    Following
    0
    For some reason, banding shows up more in CS3 than CS2. Try going up to 16 Bits per Channel (Image->Mode-16 Bits/Channel) and trying Gaussian Blur or whatever it is that you are smoothing out the gradient with.

    Reply With Quote Reply With Quote  

  7. #6
    Join Date
    Nov 2008
    Location
    Pacific Northwest, USA
    Posts
    60
    Thanks
    18
    Thanked 19 Times in 15 Posts
    Follows
    0
    Following
    0
    The next obvious answer (actually, probably the first obvious answer, but I just didn't think of it) is to select the area, place it on it's own layer, and insert a gradient using the gradient tool. Assuming the layer is set to "Normal," it will cover up any odd brushstrokes or imperfections in the original layer.

    On a side note, it seems counter-intuitive (and very time intensive) to build shadows with brushes (even soft brushes) if what you are really looking for is a smooth gradient that is best achieved with the gradient tool.

    Last night I slept like a baby: I wore a diaper.
    Reply With Quote Reply With Quote  

  8. #7
    Join Date
    Apr 2007
    Location
    Stockholm, Sweden
    Posts
    120
    Thanks
    1
    Thanked 17 Times in 14 Posts
    Follows
    0
    Following
    0
    Hmm. Thanks for the replies. Yea, banding is the word I'm looking for. That's what happens. Sigmadog: I'm not sure what you mean, but I feel building shadows through brush strokes is the most intuitive thing to do. Gradient layers is someting we do in photoshop to save time. I don't really care. The fact is that when you get into the darks the gradent tool is probably the worst thing you can use. It gets you from 80% black to 90% black in like four steps, and somehow it seems like step 2 is darker than step 3 but lighter than step 4. Anyway, it looks like shit. I'll try 16 bit from now on. I'll also try to stay out of the darks – though I really feel I shouldn't have to.

    Reply With Quote Reply With Quote  

  9. #8
    Join Date
    Feb 2008
    Posts
    170
    Thanks
    24
    Thanked 102 Times in 54 Posts
    Follows
    0
    Following
    0
    Why did you assign iMac color profile to your document?
    1-Try the blur tool with your current color profile on the undesired bands and compare -> the problem is still there
    2-Try to reopen your document and convert the embedded color profile to sRGB and try again the blur tool, you will see the desired missing value (still not perfect but a bit better).

    *EDIT Ok, I checked your sketchbook and you seem to use everytime your monitor color profile as Photoshop color space (the first images are using LCD color profile). That's a problem!
    Your monitor color profile is only needed for you because you need to be sure the color you are seeing are the right colors and that depends of the operating system only. Once your are in Photoshop, the color are already supposed to be the right colors, so you don't need to add again your monitor color profile which will convert again your color space to reduced one just like another jpeg compression.
    Use as color space something like sRGB which is a standard color space. This color space is something that never changes from one computer to another computer, it is not variable.

    Another thing, when you are saving your images for posting them on web, try to convert them to sRGB, it will convert your image to be visible identically without any color profile than with your current profile and every web browser will see the same image.
    I am using actually firefox which uses color management by default since version 3.5 (it was needed to activate it in the hidden options before -> about:config) but it is still not available in Internet Explorer 8 (ahaha). If I open this thread in IE8, the image you posted here does not look the same than the same image if I am using firefox because of color management.

    Last edited by hecartha; January 1st, 2010 at 04:24 AM.
    Reply With Quote Reply With Quote  

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
  • 424,149 Artists
  • 3,599,276 Artist Posts
  • 32,941 Sketchbooks
  • 54 New Art Jobs
Art Workshop Discount Inside
Register

Developed Actively by vBSocial.com
The Art Department
SpringOfSea's Sketchbook